Sync with Rawhide spec

This creates a proper python2-stevedore package and adds usage of
the python_provide macro in the python2 and python3 subpkgs.

Change-Id: I6620588e0d825785d0adebcd41a9a97466d06941
diff --git a/python-stevedore.spec b/python-stevedore.spec
index 385318b..66ecfa8 100644
--- a/python-stevedore.spec
+++ b/python-stevedore.spec
@@ -13,8 +13,8 @@
 Source0:        http://pypi.python.org/packages/source/s/stevedore/stevedore-%{version}.tar.gz
 BuildArch:      noarch
 
-BuildRequires:  python-devel
-BuildRequires:  python-setuptools
+BuildRequires:  python2-devel
+BuildRequires:  python2-setuptools
 BuildRequires:  python-pbr
 BuildRequires:  python-mock
 BuildRequires:  python-six
@@ -22,9 +22,6 @@
 #BuildRequires:  python-discover
 #BuildRequires:  python-oslotest
 
-Requires:       python-setuptools
-Requires:       python-six
-
 %if 0%{?with_python3}
 BuildRequires:  python3-devel
 BuildRequires:  python3-setuptools
@@ -39,13 +36,27 @@
 %description
 Manage dynamic plugins for Python applications
 
+%package -n python2-stevedore
+Summary:        Manage dynamic plugins for Python applications
+Group:          Development/Libraries
+%{?python_provide:%python_provide python2-stevedore}
+
+Requires:       python2-setuptools
+Requires:       python-six
+Requires:       python-pbr
+
+%description -n python2-stevedore
+Manage dynamic plugins for Python applications
+
 %if 0%{?with_python3}
 %package -n python3-stevedore
 Summary:        Manage dynamic plugins for Python applications
 Group:          Development/Libraries
+%{?python_provide:%python_provide python3-stevedore}
 
 Requires:       python3-setuptools
-Requires:       python-six
+Requires:       python3-six
+Requires:       python3-pbr
 
 %description -n python3-stevedore
 Manage dynamic plugins for Python applications
@@ -54,13 +65,16 @@
 %prep
 %setup -q -n stevedore-%{upstream_version}
 
+# let RPM handle deps
+rm -f requirements.txt
+
 %if 0%{?with_python3}
 rm -rf %{py3dir}
 cp -a . %{py3dir}
 %endif
 
 %build
-%{__python} setup.py build
+%{__python2} setup.py build
 
 %if 0%{?with_python3}
 pushd %{py3dir}
@@ -75,7 +89,7 @@
 popd
 %endif
 
-%{__python} setup.py install --skip-build --root %{buildroot}
+%{__python2} setup.py install --skip-build --root %{buildroot}
 
 %check
 #TODO: reenable when commented test requirements above are available
@@ -88,14 +102,16 @@
 #popd
 #%endif
 
-%files
-%doc README.rst LICENSE
-%{python_sitelib}/stevedore
-%{python_sitelib}/stevedore-*.egg-info
+%files -n python2-stevedore
+%license LICENSE
+%doc README.rst
+%{python2_sitelib}/stevedore
+%{python2_sitelib}/stevedore-*.egg-info
 
 %if 0%{?with_python3}
 %files -n python3-stevedore
-%doc README.rst LICENSE
+%license LICENSE
+%doc README.rst
 %{python3_sitelib}/stevedore
 %{python3_sitelib}/stevedore-*.egg-info
 %endif